Remi Collet : PHP version 7.3.30, 7.4.23 et 8.0.10

Les RPM de PHP version 8.0.10 sont disponibles dans le dépôt remi-php80 pour Fedora 32-34 et Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 7.4.23 sont disponibles dans le dépôt remi pour Fedora 32-34 et dans le dépôt remi-php74 pour Enterprise Linux (RHEL, CentOS).

Les RPM de PHP version 7.3.30 sont disponibles dans le dépôt remi-php73 pour Enterprise Linux (RHEL, CentOS).

PHP version 7.2 a atteint sa fin de vie et n’est plus maintenu par le projet PHP.

Ces versions sont aussi disponibles en Software Collections dans le dépôt remi-safe et en module pour Fedora 32-34 et EL-8.

Ces versions corrigent quelques failles de sécurité, la mise à jour est donc vivement recommandée.

Annonces des versions :

Installation : voir l’assistant de configuration et choisir la version et le mode d’installation.

Remplacement du PHP par défaut du système par la version 8.0 (le plus simple) :

yum-config-manager --enable remi-php80
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module reset php
dnf module enable php:remi-8.0
dnf update php*

Installation en parallèle, en Software Collection de PHP 8.0

yum install php80

Remplacement du PHP par défaut du système par la version 7.4 (le plus simple) :

yum-config-manager --enable remi-php74
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.4
dnf update php*

Installation en parallèle, en Software Collection de PHP 7.4

yum install php74

Remplacement du PHP par défaut du système par la version 7.3 (le plus simple) :

yum-config-manager --enable remi-php73
yum update

ou, en utilisant le module (Fedora et EL-8) :

dnf module enable php:remi-7.3
dnf update php*

Installation en parallèle, en Software Collection de PHP 7.3

yum install php73

Et bientôt dans les mises à jour officielles:

À noter :

  • les paquets EL-8 sont construits avec RHEL-8.4
  • les paquets EL-7 sont construits avec RHEL-7.9
  • les paquets EL-7 utilisent désormais libicu65 (version 65.1)
  • les paquets EL utilisent désormais oniguruma5php (version 6.9.7, au lieu de la version ancienne du système)
  • l’extension oci8 utilise désormais le client Oracle version 21.1
  • beaucoup d’ extensions sont aussi disponible, voir PHP extensions RPM status (from PECL and other sources) page

Informations, lire :

Paquets de base (php)

Software Collections (php73 / php74 / php80)

Aller à la source
Author:

Publié le
Catégorisé comme RPM